WordPress Vulnerability Report: May 2021, Part 3

Vulnerable plugins and themes are the #1 reason WordPress websites get hacked. The weekly WordPress Vulnerability Report powered by WPScan covers recent WordPress plugin, theme, and core vulnerabilities, and what to do if you run one of the vulnerable plugins or themes on your website.

Each vulnerability will have a severity rating of LowMediumHigh, or Critical. Responsible disclosure and reporting of vulnerabilities is an integral part of keeping the WordPress community safe. Please share this post with your friends to help get the word out and make WordPress safer for everyone.

In the May, Part 3 Report

WordPress Core Vulnerabilities

This week, we saw a WordPress 5.7.2 security release with one security issue affecting WordPress versions between 3.7 and 5.7. If you haven’t yet updated to 5.7, all WordPress versions since 3.7 have also been updated to fix an Object Injection in PHPMailer security issue.

1. WordPress 5.7.2 Security Release

Vulnerability: Object Injection in PHPMailer
Patched in Version: 5.7.2
Severity Score: Medium

The vulnerability has been patched, so you should update all your sites today to WordPress 5.7.2.

WordPress Plugin Vulnerabilities

1. Photo Gallery

Plugin: Photo Gallery
Vulnerability: Authenticated Stored Cross-Site Scripting via Gallery Title
Patched in Version: 1.5.67
Severity: Medium

The vulnerability is patched, so you should update to version 1.5.67+.

2. Weekly Schedule

Plugin: Weekly Schedule
Vulnerability: Authenticated Stored Cross-Site Scripting
Patched in Version: 3.4.3
Severity Score: Medium

The vulnerability is patched, so you should update to version 3.4.3+.

3. External Media 

Plugin: External Media
Vulnerability: Authenticated Arbitrary File Upload
Patched in Version: 1.0.34
Severity Score: Critical

The vulnerability is patched, so you should update to version 1.0.34+.

4. WP Super Cache

Plugin: WP Super Cache
Vulnerability: Authenticated Remote Code Execution
Patched in Version: 1.7.3
Severity Score: High

The vulnerability is patched, so you should update to version 1.7.3+.

5. Database Backup for WordPress

Plugin: Database Backup for WordPressVulnerability: Authenticated Persistent Cross-Site Scripting
Patched in Version: 2.4
Severity Score: Medium

The vulnerability is patched, so you should update to version 2.4+.

WordPress Theme Vulnerabilities

1. Mediumish

Theme: Mediumish
Vulnerability: Unauthenticated Reflected Cross-Site Scripting
Patched in Version: No known fix
Severity Score: Medium

This vulnerability has NOT been patched. Uninstall and delete the theme until a patch is released.

2. Listeo

Theme: Listeo
Vulnerability: Multiple XSS & XFS vulnerabilities
Patched in Version: 1.6.11
Severity Score: Medium

Vulnerability: Multiple Authenticated IDOR Vulnerabilities
Patched in Version: 1.6.11
SeverityScore: Medium

The vulnerability is patched, so you should update to version 1.6.11+.

3. Bello

Theme: Listeo
Vulnerability: Authenticated XSS & XFS
Patched in Version: 1.6.0
Severity Score: Medium

Vulnerability: Unauthenticated Reflected XSS & XFS
Patched in Version: 1.6.0
SeverityScore: Medium

Vulnerability: Unauthenticated Blind SQL Injection
Patched in Version: 1.6.0
SeverityScore: Critical

The vulnerability is patched, so you should update to version 1.6.0+.

A Note on Responsible Disclosure

You might be wondering why a vulnerability would be disclosed if it gives hackers an exploit to attack. Well, it is very common for a security researcher to find and privately report the vulnerability to the software developer.

With responsible disclosure, the researcher’s initial report is made privately to the developers of the company that owns the software, but with an agreement that the full details will be published once a patch has been made available. For significant security vulnerabilities, there may be a slight delay in disclosing the vulnerability to give more people time to patch.

The security researcher may provide a deadline for the software developer to respond to the report or to provide a patch. If this deadline is not met, then the researcher may publicly disclose the vulnerability to put pressure on the developer to issue a patch.

Publicly disclosing a vulnerability and seemingly introducing a Zero-Day vulnerability–a type of vulnerability that has no patch and is being exploited in the wild– may seem counterproductive. But, it is the only leverage that a researcher has to pressure the developer to patch the vulnerability.

If a hacker were to discover the vulnerability, they could quietly use the Exploit and cause damage to the end-user(this is you), while the software developer remains content on leaving the vulnerability unpatched. Google’s Project Zero has similar guidelines when it comes to disclosing vulnerabilities. They publish the full details of the vulnerability after 90 days whether or not the vulnerability has been patched.

How to Protect Your WordPress Website From Vulnerable Plugins and Themes

The iThemes Security Pro plugin’s Site Scanner is another way to secure and protect your WordPress website from the number one cause of all software hacks: outdated plugins and themes with known vulnerabilities.  The Site Scanner checks your site for known vulnerabilities and automatically applies a patch if one is available.

The 3 Types of WordPress Vulnerabilities Checked

  1. WordPress Vulnerabilities
  2. Plugin Vulnerabilities
  3. Theme Vulnerabilities

To enable the Site Scan on new installs, navigate to the iThemes Security Pro settings and click the Enable button on the Site Scan settings module.

To trigger a manual Site Scan, click the Scan Now button on the Site Scan Widget located on the right side-bar of the security settings.

The Site Scan results will display in the widget.

If the Site Scan detects a vulnerability, click the vulnerability link to view the details page.

On the Site Scan vulnerability page, you will see if there is a fix available for the vulnerability. If there is a patch available, you can click the Update Plugin button to apply the fix on your website.

There can be a delay between when a patch is available and the iThemes Security Vulnerability Database getting updated to reflect the fix. In this case, you can mute the notification to not receive any more alerts related to the vulnerability.

Important: You should not mute a vulnerability notification until you have confirmed your current version includes a security fix, or the vulnerability doesn’t affect your site.

iThemes Security Pro, our WordPress security plugin, offers 50+ ways to secure and protect your website from common WordPress security vulnerabilities. With WordPress, two-factor authentication, brute force protection, strong password enforcement, and more, you can add an extra layer of security to your website.

Get iThemes Security Pro

Spread the love

Posted by News Monkey

blank