WordPress Vulnerability Report: April 2021, Part 2

New WordPress plugin and theme vulnerabilities were disclosed during the second week of April. This post covers the recent WordPress plugin, theme, and core vulnerabilities and what to do if you run one of the vulnerable plugins or themes on your website.

The WordPress Vulnerability Roundup is divided into three different categories: WordPress core, WordPress plugins, and WordPress themes.

Each vulnerability will have a severity rating of LowMediumHigh, or Critical. The severity ratings are based on the Common Vulnerability Scoring System.

In the April, Part 2 Report

WordPress Core Vulnerabilities

Great news! No new WordPress core vulnerabilities have been disclosed this month.

The latest version of WordPress is currently 5.7. Make sure all your websites are running the latest version of WordPress core.

WordPress Plugin Vulnerabilities

This section covers vulnerabilities in WordPress plugins with instructions on whether to update or remove the vulnerable plugin.

1. iThemes Security Free & Pro

Vulnerability: Hide Backend Bypass
Patched in Version (iThemes Security): 7.9.1
Patched in Version (iThemes Security Pro): 6.8.4
Severity: High – CVSS:3.1AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/

The Hide Backend feature in iThemes Security allows users to hide the login page by changing its name and preventing access to wp-login.php and wp-admin. A bug was discovered in versions below 7.9.1 of iThemes Security and below 6.8.4 of iThemes Security Pro that make the hidden login page discoverable, reducing the effectiveness of the feature.

Update to version 7.9.1 of iThemes Security and 6.8.4 of iThemes Security Pro to receive the Hide Backed bypass workaround patch.

Note: You should be aware that the hide backend feature isn’t full-proof no matter how much we try to improve it. In fact, the effectiveness of hiding the login page of your website for security reasons is our #1 WordPress security myth. Why? The truth is that you can’t completely hide the backend of your website. The login page may be exposed by WordPress core, plugins, or themes when printing links to the login page (like Privacy Request Confirmations or front-end login forms). 

Hide Backend shouldn’t be used as a substitute for superior website security measures, like enforcing strong passwords and two-factor authentication.

2. Simple Membership

Vulnerability: Authenticated SQL Injections
Patched in Version: 4.0.4
Severity: Critical – CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L

The vulnerability is patched, so you should update to version 4.0.4.

4. OpenID Connect Generic Client

Vulnerability: Reflected Cross-Site Scripting
Patched in Version: 3.8.2
Severity: Medium – CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

The vulnerability is patched, so you should update to version 3.8.2+.

5. Stop Spammers

Vulnerability: Reflected Cross-Site Scripting
Patched in Version: 2021.9
Severity: Medium – CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

The vulnerability is patched, so you should update to version 2021.9.

6. Imagements

Vulnerability: Unauthenticated Arbitrary File Upload to RCE
Patched in Version: No known fix
Severity: Critical – CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

7. WorkScout Core Plugin

Vulnerability: Authenticated Stored XSS & XFS
Patched in Version: 1.3.4
Severity: High – CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

The vulnerability is patched, so you should update to version 1.3.4+.

8. Larsens Calender

Vulnerability: Stored Cross-Site Scripting
Patched in Version: No known fix
Severity: High – CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

9. Contact Form Check Tester 

Vulnerability: Broken Access Control to Cross-Site Scripting
Patched in Version: No known fix
Severity: High – CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

10. Business Directory Plugin

Vulnerability: Arbitrary Listing Export
Patched in Version: 5.11.2
Severity: High – CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

Vulnerability: Arbitrary Payment History Update
Patched in Version: 5.11.2
Severity: Medium – CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability: Authenticated Stored Cross-Site Scripting
Patched in Version: 5.11.2
Severity: Medium – CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L

The vulnerability is patched, so you should update to version 5.11.2+.

11. Event Banner

Vulnerability: Arbitrary File Upload to RCE
Patched in Version: No known fix
Severity: Critical – CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

12. Classyfrieds

Vulnerability: Authenticated Arbitrary File Upload to RCE
Patched in Version: No known fix
Severity: Critical – CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

13. College Publisher Import 

Vulnerability: Arbitrary File Upload to RCE
Patched in Version: No known fix
Severity: Critical – CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

WordPress Theme Vulnerabilities

1. WorkScout Core Theme

Vulnerability: Authenticated Stored XSS & XFS
Patched in Version: 2.0.33
Severity: High – CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

The vulnerability is patched, so you should update to version 2.0.33+.

A WordPress Security Plugin Can Help Secure Your Website

iThemes Security Pro, our WordPress security plugin, offers 50+ ways to secure and protect your website from common WordPress security vulnerabilities. With WordPress, two-factor authentication, brute force protection, strong password enforcement, and more, you can add an extra layer of security to your website.

Get iThemes Security Pro

WordPress vulnerability report

Spread the love

Posted by News Monkey

blank