WordPress Vulnerability Report: June 2021, Part 5

Spread the love

Vulnerable plugins and themes are the #1 reason WordPress websites get hacked. The weekly WordPress Vulnerability Report powered by WPScan covers recent WordPress plugin, theme, and core vulnerabilities, and what to do if you run one of the vulnerable plugins or themes on your website.

Each vulnerability will have a severity rating of LowMediumHigh, or Critical. Responsible disclosure and reporting of vulnerabilities is an integral part of keeping the WordPress community safe. Please share this post with your friends to help get the word out and make WordPress safer for everyone.

In the July, Part 1 Report
Sign up for the weekly WordPress Security News & Updates newsletter

WordPress Core Vulnerabilities

WordPress Plugin Vulnerabilities

This section lists recent plugin vulnerabilities. Each plugin in this list includes the plugin name, vulnerability type, patch version info, and a severity rating of the vulnerability.

1. Browser Screenshots

Plugin: Browser Screenshots
Vulnerability: Stored Cross-Site Scripting
Patched in Version: 1.7.6
Severity: Medium

The vulnerability is patched, so you should update to version 1.7.6+.

2. Sign-up Sheets

Plugin: Sign-up Sheets
Vulnerability: Authenticated Stored Cross-Site Scripting
Patched in Version: 1.0.14
Severity Score: Medium

Plugin: Sign-up Sheets
Vulnerability: Authenticated CSV Injection
Patched in Version: 1.0.14
Severity Score: Medium

The vulnerabilities have been patched, so you should update to version 1.0.14+.

3. Prismatic

Plugin: Prismatic
Vulnerability: Reflected Cross-Site Scripting
Patched in Version: 2.8
Severity Score: High

Plugin: Prismatic
Vulnerability: Stored Cross-Site Scripting
Patched in Version: 2.8
Severity Score: Medium

The vulnerabilities have been patched, so you should update to version 2.8+.

4. Glass

Plugin: Glass
Vulnerability: CSRF to Stored Cross-Site Scripting
Patched in Version: No known fix
Severity Score: High

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

Plugin: Simple Sort&Search
Vulnerability: Stored Cross-Site Scripting
Patched in Version: No known fix
Severity Score: Medium

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

6. Salon Booking System

Plugin: Salon Booking System
Vulnerability: Unauthenticated Stored Cross-Site Scripting
Patched in Version: 6.3.1
Severity Score: Critical

The vulnerability is patched, so you should update to version 6.3.1+.

7. Qtranslate Slug

Plugin: Qtranslate Slug
Vulnerability: CSRF
Patched in Version: No known fix
Severity Score: Medium

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

8. Multivendor Marketplace Solution for WooCommerce 

Plugin: Multivendor Marketplace Solution for WooCommerce
Vulnerability: CSRF
Patched in Version: 3.7.4
Severity Score: Medium

The vulnerability is patched, so you should update to version 3.7.4+.

9. Custom css-js-php

Plugin: Custom css-js-php
Vulnerability: CSRF
Patched in Version: No known fix
Severity Score: Medium

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

10. Absolute Reviews

Plugin: Absolute Reviews
Vulnerability: CSRF
Patched in Version: 1.0.9
Severity Score: Medium

The vulnerability is patched, so you should update to version 1.0.9+.

11. Advanced Popups

Plugin: Advanced Popups
Vulnerability: CSRF
Patched in Version: 1.1.2
Severity Score: Medium

The vulnerability is patched, so you should update to version 1.1.2+.

12. Remove Schema

Plugin: Remove Schema
Vulnerability: CSRF
Patched in Version: 1.6
Severity Score: Medium

The vulnerability is patched, so you should update to version 1.6+.

13. Multiple Roles

Plugin: Multiple Roles
Vulnerability: CSRF
Patched in Version: No known fix
Severity Score: Medium

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

14. Sunshine Photo Cart

Plugin: Sunshine Photo Cart
Vulnerability: CSRF
Patched in Version: 2.8.29
Severity Score: Medium

The vulnerability is patched, so you should update to version 2.8.29+.

15. Ultimate Gift Cards

Plugin: Ultimate Gift Cards
Vulnerability: CSRF
Patched in Version: 2.1.2
Severity Score: Medium

The vulnerability is patched, so you should update to version 2.1.2+.

16. wp-mpdf

Plugin: wp-mpdf
Vulnerability: CSRF
Patched in Version: 3.5.2
Severity Score: Medium

The vulnerability is patched, so you should update to version 3.5.2+.

17. Export Users With Meta

Plugin: Export Users With Meta
Vulnerability: Authenticated SQL Injection
Patched in Version: 0.6.5
Severity Score: Medium

The vulnerability is patched, so you should update to version 0.6.5+.

18. YOP Poll

Plugin: YOP Poll
Vulnerability: 6.2.8
Patched in Version: Unauthenticated Stored Cross-Site Scripting
Severity Score: Medium

The vulnerability is patched, so you should update to version 6.2.8+.

19. Fudousan

Plugin: Fudousan
Vulnerability: Authenticated Cross-Site Scripting
Patched in Version: 5.7.2
Severity Score: Medium

The vulnerability is patched, so you should update to version 5.7.2+.

20. Poll, Survey, Questionnaire and Voting system

Plugin: Poll, Survey, Questionnaire and Voting system
Vulnerability: Unauthenticated Blind SQL Injection
Patched in Version: 1.5.3
Severity Score: Critical

The vulnerability is patched, so you should update to version 1.5.3+.

21. CiviCRM

Plugin: CiviCRM
Vulnerability: CSRF to Stored Cross-Site Scripting
Patched in Version: 5.28.1
Severity Score: Medium

The vulnerability is patched, so you should update to version 5.28.1+.

22. WP Image Zoom

Plugin: WP Image Zoom
Vulnerability: Local File Inclusion
Patched in Version: 1.47
Severity Score: Medium

The vulnerability is patched, so you should update to version 1.47+.

23. ZoomSounds

Plugin: ZoomSounds
Vulnerability: Unauthenticated Arbitrary File Upload
Patched in Version: 6.05
Severity Score: Critical

The vulnerability is patched, so you should update to version 6.05+.

24. Include Me

Plugin: Include Me
Vulnerability: Authenticated Remote Code Execution
Patched in Version: No known fix
Severity Score: High

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

WordPress Theme Vulnerabilities

No new WordPress theme vulnerabilities to report.

A Note on Responsible Disclosure

You might be wondering why a vulnerability would be disclosed if it gives hackers an exploit to attack. Well, it is very common for a security researcher to find and privately report the vulnerability to the software developer.

With responsible disclosure, the researcher’s initial report is made privately to the developers of the company that owns the software, but with an agreement that the full details will be published once a patch has been made available. For significant security vulnerabilities, there may be a slight delay in disclosing the vulnerability to give more people time to patch.

The security researcher may provide a deadline for the software developer to respond to the report or to provide a patch. If this deadline is not met, then the researcher may publicly disclose the vulnerability to put pressure on the developer to issue a patch.

Publicly disclosing a vulnerability and seemingly introducing a Zero-Day vulnerability–a type of vulnerability that has no patch and is being exploited in the wild– may seem counterproductive. But, it is the only leverage that a researcher has to pressure the developer to patch the vulnerability.

If a hacker were to discover the vulnerability, they could quietly use the Exploit and cause damage to the end-user(this is you), while the software developer remains content on leaving the vulnerability unpatched. Google’s Project Zero has similar guidelines when it comes to disclosing vulnerabilities. They publish the full details of the vulnerability after 90 days whether or not the vulnerability has been patched.

How to Protect Your WordPress Website From Vulnerable Plugins and Themes

As you can see from this report, lots of new WordPress plugin and theme vulnerabilities are disclosed each week. We know it can be difficult to stay on top of every reported vulnerability disclosure, so the iThemes Security Pro plugin makes it easy to make sure your site isn’t running a theme, plugin or WordPress core version with a known vulnerability.

1. Turn on the iThemes Security Pro Site Scanner

The iThemes Security Pro plugin’s Site Scanner scans for the #1 reason WordPress sites get hacked: outdated plugins and themes with known vulnerabilities. The Site Scanner checks your site for known vulnerabilities and automatically applies a patch if one is available.

To enable the Site Scan on new installs, navigate to the Site Check tab on the Features menu inside the plugin and click the toggle to enable the Site Scan.

To trigger a manual Site Scan, click the Scan Now button on the Site Scan Security Dashboard card.

If the Site Scan detects a vulnerability, click the vulnerability link to view the details page.

On the Site Scan vulnerability page, you will see if there is a fix available for the vulnerability. If there is a patch available, you can click the Update Plugin button to apply the fix on your website.

2. Turn on Version Management

The Version Management feature in iThemes Security Pro integrates with the Site Scan to protect your site when outdated software is not updated quickly enough. Even the strongest security measures will fail if you are running vulnerable software on your website. These settings help protect your site with options to update to new versions automatically if a known vulnerability exists and a patch is available.

From the Settings page in iThemes Security Pro, navigate to the Features screen. Click the Site Check tab. From here, use the toggle to enable Version Management. Using the settings gear, you can configure even more settings, including how you want iThemes Security Pro to handle updates to WordPress, plugins, themes, and additional protection.

Make sure to select Auto Update if Fixes a Vulnerability box so that iThemes Security Pro will automatically update a plugin or theme if it fixes a vulnerability that was found by the Site Scanner.

iThemes Security Pro version management

3. Get an Email Alert When iThemes Security Pro Finds a Known Vulnerability On Your Site

Once you’ve enabled Site Scan Scheduling, head to the Notification Center settings of the plugin. On this screen, scroll to the Site Scan Results section.

Click the box to enable the notification email and then click the Save Settings button.

Now, during any scheduled site scans, you’ll get an email if iThemes Security Pro discovers any known vulnerabilities. The email will look something like this.

site-scan-results
iThemes Security 7.0

Get iThemes Security Pro Today!

iThemes Security Pro, our WordPress security plugin, offers 50+ ways to secure and protect your website from common WordPress security vulnerabilities. With WordPress, two-factor authentication, brute force protection, strong password enforcement, and more, you can add an extra layer of security to your website.

This week, we’re celebrating the release of iThemes Security Pro 7.0 with a sale so you can upgrade all your sites to Pro. Just use coupon code 7POINTOH at checkout on any new iThemes Security Pro purchase* through June 30, 2021.

Get iThemes Security Pro

Each week, Michael puts together the WordPress Vulnerability Report to help keep your sites safe. As Product Manager at iThemes, he helps us continue to improve the iThemes product lineup. He’s a giant nerd & loves learning about all things tech, old & new. You can find Michael hanging out with his wife & daughter, reading or listening to music when not working.

Posted by News Monkey

blank