Keeping phpBB up-to-date closes security holes

With the continued development of cPanel/WHM, there are bound to be changes in the way things are handled via the control panel. More recently, one of those is how add-on scripts are handled both in installation and management/updating.

"Addon Scripts" has been replaced within WHM with "Install cPAddon Scripts" (in your WHM, you might even see a link named "Addon Scripts (Deprecated)."

The Addon Script Manager previously utilized to update scripts cPanel can install has been replaced with "Manage cPAddon Scripts."

Installs of scripts, like phpBB, can only be "managed" or mass upgraded automatically by the script manager that installed it. That is to say, if you previously installed phpBB via "Addon Scripts" you will not be able to update it via "Managed cPAddon Scripts." In this case, you will need to use the "Addon Script Manager"

NOTE: Since Addon Scripts have been deprecated, updates for the scripts via the addon scripts manager are not up to date!!! That means you will need to manually update these installations to the latest version.

At the time of this writing, the Addon Script manager considered phpBB 2.0.17 up to date, while cPAddon Scripts was installing 2.0.21.

Remember that no matter what cPanel script manager you utilize, it will update the installs of phpBB that were installed via cpanel only.

Manuall installations of phpBB will NOT be updated via this method and must be updated manually. http://www.phpbb.com/downloads.php has more information on the latest version available.

http://www.phpbb.com/security/ provides a listing of known security vulnerabilities.

Spread the love
blank