cPanel easy apache3 not wanting to play ball

Just recently we had a little glitch on one of our cPanel server which we wanted to upgrade to Apache2.2.8
All of a sudden the recompiling process of Apache did not want to start and we got those errors

–> Running transaction check
–> Processing Dependency: glibc-common = 2.5-12 for package: glibc
Error: No Package Matching glibc.i686
!! Could not ensure pkglist ‘zlib1-devel, automake19, expat-devel, gettext,
libstdc++.x86_64, libpng-devel, libopenssl0-dev, openssl, gcc-c++, glibc-devel,
expat, libpng-dev, zlib-devel, zlib, bison, autoconf261, libidn-devel, gmake,
libidn, libXpm, libjpeg-devel, openssl-devel, automake, coreutils,
libtool-libltdl-devel, libopenssl0, openssl-dev, libtool, patch, libz-devel,
libltdl3-devel, libltdl, libjpeg-dev, libopenssl0.9.7-static-devel, pam-dev,
libtool-ltdl-devel, libopenssl0.9.7-devel, libltdl-devel, fileutils,
libXpm-devel, sed, libXpm-dev, krb5-dev, flex, glibc-dev, expat-dev,
krb5-devel, libstdc++-devel.x64_64, make, libstdc++-dev.x86_64, xorg-x11-devel,
libssl-dev, libstdc++-devel.x86_64, gd, pam-devel, cpp, xorg-x11-dev, gcc,
libopenssl0-devel, ssl-dev, lex, autoconf’ !!
!! Please visit
http://www.cpanel.net/support/could_not_ensurepkgs.htm
for help with this error. !!
!! Restoring original working apache !!
!! Executing ‘/scripts/initfpsuexec’ !!
!! Executing ‘/scripts/initsslhttpd’ !!
!! Verbose logfile is at ‘/usr/local/cpanel/logs/easy/apache/build.1201530758’

Very annoying , isnt it

So we did a yum upgrade and a force upcp and tried to recompile again with this new result

–> Running transaction check
–> Processing Dependency: glibc-common = 2.5-12 for package: glibc
Error: No Package Matching glibc.i686
!! Could not ensure pkglist ‘zlib1-devel, automake19, expat-devel, gettext,
libstdc++.x86_64, libpng-devel, libopenssl0-dev, openssl, gcc-c++, glibc-devel,
expat, libpng-dev, zlib-devel, zlib, bison, autoconf261, libidn-devel, gmake,
libidn, libXpm, libjpeg-devel, openssl-devel, automake, coreutils,
libtool-libltdl-devel, libopenssl0, openssl-dev, libtool, patch, libz-devel,
libltdl3-devel, libltdl, libjpeg-dev, libopenssl0.9.7-static-devel, pam-dev,
libtool-ltdl-devel, libopenssl0.9.7-devel, libltdl-devel, fileutils,
libXpm-devel, sed, libXpm-dev, krb5-dev, flex, glibc-dev, expat-dev,
krb5-devel, libstdc++-devel.x64_64, make, libstdc++-dev.x86_64, xorg-x11-devel,
libssl-dev, libstdc++-devel.x86_64, gd, pam-devel, cpp, xorg-x11-dev, gcc,
libopenssl0-devel, ssl-dev, lex, autoconf’ !!
!! Please visit
http://www.cpanel.net/support/could_not_ensurepkgs.htm
for help with this error. !!
!! Restoring original working apache !!
!! Executing ‘/scripts/initfpsuexec’ !!
!! Executing ‘/scripts/initsslhttpd’ !!
!! Verbose logfile is at ‘/usr/local/cpanel/logs/easy/apache/build.1201530758’

So it appeared easyapache had  problems with the krb5 packages

Tried to find the related packages

rpm -qa | grep krb5

and got those results

krb5-libs-1.5-29
pam_krb5-2.2.14-1
krb5-devel-1.6.1-17.el5
krb5-devel-1.5-29
krb5-libs-1.5-29
pam_krb5-2.2.11-1
krb5-workstation-1.5-29
krb5-libs-1.6.1-17.el5
pam_krb5-2.2.11-1
krb5-devel-1.5-29
krb5-libs-1.6.1-17.el5
pam_krb5-2.2.14-1

So I deleted the conflicting packages including the dependances ( –allmatches will show you the info , for example :  rpm -e –allmatches krb5-libs-1.5-29 )

 rpm -e –allmatches krb5-libs-1.5-29 krb5-devel-1.5-29.i386 krb5-devel-1.5-29.x86_646 openssl-devel-0.9.8b-8.3.el5_0.2.x86_64

So by deleting hopefully eapache will start
I run another  force upcp and the new attempt of recompiling Apache to 2.2.8 with easyapache 3 in WHM was successful 🙂

Additional info:
To find your easyapache error logs go here

cd /usr/local/cpanel/logs/easy/apache/

I guess you could call this, trials and tribulations of a cPanel Junkie 🙂

Facebook Comments
Spread the love

Posted by News Monkey